Game System Request: Powered by the Apocalypse - Myth-Weavers


Site Discussion

Do you have questions, suggestions, feedback, bug reports or other concerns? Post them here!


Game System Request: Powered by the Apocalypse

   
Game System Request: Powered by the Apocalypse

My Browser Information: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Relevant Links: (Copy and paste links to what it is you're talking about here)
Referrer: https://www.myth-weavers.com/forumdisplay.php?f=8

Message: (Describe your issue or feedback here, in as much detail as possible)


Would it be possible to add the Powered by the Apocalypse to the Games when posting a new game?

If nothing else it'd be more accurate than Homebrew / Other.

Apocalypse World or Dungeon World is probably as close as it currently gets. However I see your point...the System should be PbtA, and the Settings should be Dungeon World, Apocalylse World, Tremulus, etc....

Quote:
Originally Posted by TatteredKing View Post
Apocalypse World or Dungeon World is probably as close as it currently gets. However I see your point...the System should be PbtA, and the Settings should be Dungeon World, Apocalylse World, Tremulus, etc....
Yeah. It would help when setting up something like a game of MASHED or Night Witches, as there are many subset games within the system. Apocalypse World and others are just the most well-known.








Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Last Database Backup 2019-08-21 09:00:05am local time
Myth-Weavers Status