March 29 Update: Third Time's the Charm - Page 2 - Myth-Weavers

Notices


March 29 Update: Third Time's the Charm

 
So i have a quick question, what part of the signon is the problem here? When i logged in after the first attempt, and when checking the test page i noticed the social logins (Facebook, Twitter, Google) but i just used my email. If you DON'T use one of the social logins, and just use your email, does the fact its going through a 'social login' that is like those used by facebook et al cause the problem?

It seemed to me when i first used it a littlethat it there was the option between using an authorized 'app' (like facebook) to log in, and using your email. But the email login may still go through the social login path and cause the same problem. So what, precisely, do we think the problem is. Is it the gateway or the method of logging in. If you use your email and not a social login - like facebook - would it still cause a problem?

I assume it would but since i'm not sure the method i can't be sure, it just seemed that there were still two ways to log in, at least at the front end.

@PigLickJF You can visit the test site signon page, http://signon.test.myth-weavers.com/login and see if it ends up being blocked.

@Neopopulas It's not clear to me exactly what criteria, of his company's web filter, our signon system is fulfilling. I'm also not sure what page is being blocked - it could be that he can't even see the login page, or it could be that submitting the login page trips off the filter.

When you sign in with your email, there's nothing about it that's any different than signing into any other site. No information goes to any other provider. There's a little bit of redirecting between the forums, wiki, and sheets back to our own signon domain to facilitate sharing the login, but none of that goes through any other provider, and most actually happens behind the scenes.

From that initial login page, there are also no direct links to the actual facebook, google, or twitter pages. They link to an internal page which then redirects out to the correct provider.

So, again, it's unclear to me why it's being blocked - we already have direct links to FB and Twitter on every page. It could be that the test site is in facebook, twitter, and google's network of social-login-enabled sites, and that's what the filter is checking. It's also interesting that just the test site is blocked, when it's a subdomain of the main site. It makes me wonder if just the signon domain is getting blocked, and that the rest of the site is still available (though, naturally, authentication wouldn't be possible).

My work does have social media restrictions where pages like Facebook / Twitter / Instagram / Pinterest etc are blocked, but I was still able to log in through the test site using my email and password. It doesn't look like it's across the board on sites that have some kind of block on social media.

Well I just tested it and I should be fine, for now at least. I honestly don't even know if Facebook is blocked for me at work, I've never tried it, but I know I've hit on sites in the past that are blocked, so there is some sort of blocking going on, and things like Facebook seem like likely candidates.

Seph, maybe if you provide a bit more information about exactly which point in the process caused the issue it could be helpful? Was it when you just went to the test page, when you clicked the link to go to the login page, or when you clicked on the Login button on the login page?

I just have one question. After this update goes down will my email be visible to other people here? Because I don't want it to be for obvious reasons.

So I tried signing on the test server and I keep getting this message.

Quote:
That username is already in use or does not meet the administrator's standards. If you are Prof. Jb Wolf and you have forgotten your password, click here.
I believe I had the same problem the last time there was an update want wanted to know if there was a fix or anything I should do?

@PPQ_Purple
Quote:
Originally Posted by Rodrigo View Post
Your emails will remain private as they currently do. They're just used for logging in, and as a point of contact for any thread subscriptions, notifications, password resets, etc.
@Prof. Jb Wolf I wonder if it's due to the period in the username. I'll look into that, thanks for trying out the test server!

I checked it out and am completely fine as logging in. It did take about 3x as long as usual to log in though. Not sure why.

@natural19 The test server is running on fewer resources than the production site, so slow load times are to be expected.







 

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Last Database Backup 2018-11-16 09:00:07am local time
Myth-Weavers Status