!_! Need Fedora Linux Wireless Card Help !_! - Myth-Weavers


General Discussion

All-purpose section for discussions that donít clearly belong in any of the other categories.

!_! Need Fedora Linux Wireless Card Help !_!

!_! Need Fedora Linux Wireless Card Help !_!

Right off the bat I will admit I am new to Linux and Fedora.

I just purchased the Linux/Fedora Compatible Edimax EW-7128g Wireless Card for my new pc.

We installed the wireless card, and to our relief it was instantly recognized by Network Manager as wlan0. Now though we continue to get an error telling us it is unable to retrieve IP Address when I attempt to activate the device.

The kicker is that I am able to activate and get the lights on the back of the card to light up when I change the option of retrieving the IP automatically to a static one, even if the static one is complete garbage or the local host IP. Even when I do this I am regrettably unable to connect.

Our router is using WEP encryption, just for the record and we haven't yet tried to connect with it disabled.

I am using a fresh install of Fedora 9 that was installed and set up on a custom computer that I just ordered. I did a wlan0 scan and used the lspci commands as suggested in the fedora forums and it was able to find my ESSID :/ so I am at a standstill, it is 1am, and I am very very sleepy....

# lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:06.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
01:07.0 Network controller: RaLink RT2561/RT61 802.11g PCI
02:00.0 VGA compatible controller: nVidia Corporation NV44 [GeForce 6200 LE] (rev a1)

Any suggestions would be a godsend .... we have a network admin in the family and he is as stumped as I am, it doesn't help that he is inept at Linux as well...

Are you sure you have the DHCP server's address properly set on the Linux box? If you're not getting an IP, you might want to try a proper static IP(don't forget the gateway), with a static route on the router...

I'm pushed for time right now so I'm gonna keep my fimgers crossed and post something. It's possible that the newtwork manager on F9 is diffrent but I don't have time to check it out so try this.

There was a problem at running IP6 & IP4 together. You should be able to turn off IPv6 in the same tab as you set the static IP.

Fedora IRC channel is very helpful or try me on IM later.

EDIT: I notice you don't explicitly say you've entered your wep key.?

I will try out all of these suggestions when my brother gets home. He is at school now, and I dont know his wep key, we had put it in last night and it wasnt working still though.

We are all new to Linux here as I said , so we were at a bit of a loss as to what we had to put in and what the computer would garnish from the connection itself. I'll make sure he manually does it all when he gets home.

Then when messing with it at like 12:30 last night I accidentally saved over the wlan0 profile without the key saved....lol.

As of right now I am gonna try and connect it via wired lan, so best of luck to me :/ in the least I may be able to yum install Wine.

WEP? Gods, I hope not. You should be encrypting with WPA. WEP can be cracked in under 10 minutes...

However, for testing purposes it might be a good idea to temporarily disable the encryption on your wireless signal. Make sure everything else is working, then lock it down.

I was browsing a linux help forum when I came across a help guide suggesting I put in a few commands to find specific data about all aspects of my hardware and drivers and all that.

Fedora Core 9 - 2.6.25-14.fc9.x86_64

As of right now I don't have the wlan0 connection configured at all and haven't yet tried to connect it to elan. Hope this helps maybe D:

Your wireless network card is detected (shown in lspci) so basically you aren't getting an IP from DHCP which is why the lights come on when you give it a static one.

Don't know the significance of IPv6 stuff in lsmod but it appears you still have it on - there's no point so turn it off to be safe.

Unless you need high levels of security turn off SELinux, I'm not at home so can't check yet but I suspect it's an option in the services menu (and will probably need a reboot afetr saving).

Thank yah all for the help, I will have him configure it as you suggested when he gets home. On a side note, I ordered an install DVD for Fedora 10 to update and replace some files that I am missing, hehe missing c and cc and without an install dvd makes for an unhappy Renzy.

It's a joy to be unable to compile and make files, especially when I am unable to go online D: I got the computer from an custom computers site and apparently they didnt believe I'd need to be able to compile or make anything.... and in their infinite wisdom believed I didnt need the install DVD either lol

Aye, it's a Fedora installer option what type of installation you want, Programming is one.
Sounds like programming is the one you'll choose - you can see why a distributor probably wouldn't. :P

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2018 DragonByte Technologies Ltd.
Last Database Backup 2018-10-19 09:00:08am local time
Myth-Weavers Status