Formatting shortcuts not working - Myth-Weavers


Site Discussion

Do you have questions, suggestions, feedback, bug reports or other concerns? Post them here!

Formatting shortcuts not working

Formatting shortcuts not working

My Browser Information: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Relevant Links: (Copy and paste links to what it is you're talking about here)

Message: Recently formatting shortcuts like Ctrl+B and Ctrl+I no longer work for me. They were working this morning for me, but not now. Did something change? I tried both Firefox and Chrome.

I don't know about Chrome, but I just updated Firefox earlier and this website's formatting shortcuts are now being persistently overridden by the browser's (CTRL+B/I bring up the bookmark sidebar instead).

I remember having some trouble with that in the past, but not how I fixed it. Time to see if I can figure out how to make Firefox play nice again!

Hmm. For me, it seems to work fine if I'm actively typing in the text box. If not, then Firefox overrides it.

Firefox overrides shortcuts here even if I'm entering text.

That said, I checked another forum I post on and found that the exact same formatting shortcuts work fine there provided an input field is active, so maybe it's a JavaScript/HTML implementation thing. I write most of my MW posts "offline" anyway, so it's not a big deal for me.

@Dybrar I haven't had any issues with the formatting shortcuts in Firefox, so this is decidedly odd. Just out of curiosity, does clearing your cache fix the issue? (I always fall back on that as step 1.)

I also have this problem, and clearing my cache didn't fix it - but briefly reverting to version 64.0.2 did (and when Firefox immediately re-updated to 65.0 because I forgot to tell it not to, the problem returned). Like Dybrar, the shortcuts work on other sites even on version 65.0.

My Browser Information: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

Firefox updated last night and now mine is doing the same thing where it wasn't before. And clearing the cache didn't help.

Yup, clearing my cache didn't do anything either. Nor did running Firefox in safe mode, for what that is worth. (My browser information is the same as Son of Meepo's and Llyarden's, except that I'm on Windows NT 6.1 rather than 10.0.)

There's at least one quite different feature on a different site that also seems broken in 65.0 from what I've seen, though, so it all might well be on Mozilla.

I'm running into the same problem. Normally i'd avoid updating firefox but it got sneaky on me and got me in the end. I'm not sure what is causing it or why its so specific to this site - as far as i'm aware anyway.

I thought for a second it might only be in the 'quick reply' but going into advanced doesn't help.

Wild guess from someone who knows essentially nothing about this behind-the-scenes sort of business: "As of Firefox 65, the keypress event is no longer fired for non-printable keys (bug 968056), except for the Enter key, and the Shift + Enter and Ctrl + Enter key combinations (these were kept for cross-browser compatibility purposes)." It does look like the JavaScript powering the post/reply editor at MW uses 'keypress', so perhaps this is why those shortcuts have stopped working in F65?


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
User Alert System provided by Advanced User Tagging (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Last Database Backup 2019-03-18 09:00:08am local time
Myth-Weavers Status